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Integrating HomeWorks lllumination and HomeWorks QS using
the Driver Generator

1.0 Overview

This application note explores the ideal way to integrate a HomeWorks Illumination system with a
HomeWorks QS system over the local network utilizing the HomeWorks Driver Generator tool to
facilitate the creation of an importable keypad button press command set to be used within the
HomeWorks QS programming software. The command set generated by the tool will allow for the two
systems to control each other over the local area network.

Implementation of this integration will be beneficial when upgrading an lllumination system to QS.
System upgrades to HomeWorks QS deliver value but, due to the size of the systems being upgraded,
may occur in phases over time. As a result, both systems will be up and running concurrently for some
period of time as the HomeWorks QS system is gradually assigned more of the total system
responsibility in each phase of the upgrade.
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2.0 Hardware and Software Requirements

- Router/Switch for both systems to connect to

- HomeWorks Illumination Processor

- HomeWorks lllumination Software version 1.65 or newer
- HomeWorks QS Processor

- HomeWorks QS Software version 8.1 or newer

3.0 Configuring the HomeWorks QS System for Integration with
HomeWorks Illumination

Go to Design > Equipment and add a Control 3" Party device to an area of the area tree. Type in the IP
address of the lllumination Processor and use port 23.

Equipment Locations | I Coliapse a

Edit Command Sets Address Port Number

Integration Command Set 001 192.168.50.147 23

\Processor 1

Important Note: The login credentials for the HomeWorks lllumination system will be generated as a
separate command sent to the HomeWorks lllumination processor in a later step of this application
note.

The Inter Message Delay field should be changed to 250ms. This is the amount of time that will pass
before a command is sent.

Next, assign the lllumination Processor to the Ethernet connection of one of the HomeWorks QS
processors by selecting Link Assignment from the Design tab drop down menu. Click on Ethernet under
the Processor where the Illumination Processor is to be assigned.
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design | link assignment |+ | program

QS Project

Check the box for the Illumination Processor that you would like to assign to an Ethernet Connection
and it will appear in the list of assigned Ethernet Devices in the lower right-hand corner of the screen.

Assignable items: | Show Etnemet Devices

Item Description 4 Type & IP Address & Port

Lower Level » Equipment Room * HW Tllumination System Control 3rd Party 192.168.50.147 3

4.0 Configuring the HomeWorks Illumination System for Integration
with HomeWorks QS

In the HomeWorks lllumination software, verify the processor connected to the network on the Panel
Assignment Screen has an IP address on the same network as the HomeWorks QS processor. Go to the
Address Assignment tab and then select Link 9. Enter a username and password that the HomeWorks
QS system will use to log in to this processor. Ensure the option for Monitoring “Keypad Buttons” is
checked.
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Important Note: It is recommended to initially leave Bad Commands unchecked within the Suppress
options. If you should experience communication delays, then proceed to check the box to suppress Bad
Commands.

5.0 Using the HomeWorks Driver Generator Tool

HomeWorks QS Software 8.1 and newer can import a .csv file (typically opened and edited using
Microsoft Excel). This process creates a driver allowing the HomeWorks QS system to receive and/or
send commands to the HomeWorks Illlumination system over the local network, which is the ideal
method to integrate between the two systems. Below is a screenshot of the Driver Generator Tool and a
breakdown of each of the components to help understand how the tool is used. The latest version of the
tool can be found on the HomeWorks QS Resource Site (resi.lutron.com) and on myLutron
(www.lutron.com).

(= =] B e
| File... %
3. ‘From lllumination to Qs‘v’ 5
4, K.mdmmons
Processor Address Link Address Keypad Address KBP, [01:06:01], 1
{ﬁ: l5 ‘,\ [1 ‘,] KBDT, [02:08:02:04], 4
- . ! KBR, [03:05:06], 3
5. Action » KBH, [04:04:06], 6
Press |~|
b ——6
I{)riverSetName | ’ 1 H 2 H 3 H 4 ‘
rest Driver |
W ] ] e
umination Login:
s | (NN R
THlumination Password: ’ L H i H &2 H & ‘
B el e ]
]21\]22]]23]]24]
9 8
{ Generate Driver I Remove Highlighted
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1. File Menu:

File... |
Open...
Save

Help

Open... Open existing drivers in the .csv format. Ensure the file is not open in another program
before opening it in the tool.

Save — Save the current changes into a .csv file the HomeWorks QS software can import
(version 8.1 and newer).

Help — Opens the latest version of this application note.

2. Driver Name and Login Information:

Driver Set Name — name of the Command Set to be imported into the HomeWorks QS software

Illumination Login - Username in Link 9 of the lllumination software on the Address
Assignment tab.

Illumination Password - Password in Link 9 of the Illumination software on the Address
Assignment tab.

3. Command Direction:

From lllumination to QS |+

From llumination to Q@S
From Q5 to llumination

Specifies the direction of the commands. Each Driver file can only be generated with a single direction.

To create a Driver file with both directions, two files will be generated (one file for each direction) and

then merged with each other using a spreadsheet program such as Excel by copying the commands from

one file

a.

and pasting into the other file.

From Illumination to QS — Select this option if an lllumination button press will control the
HomeWorks QS System

From QS to Illlumination — Select this option if a HomeWorks QS button press will control the
[llumination system
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4. Processor, Link, and Keypad Addresses:

Specifies the lllumination keypad address being monitored, or sent for third party commands, and uses
the format [Processor Address: Link Address: Keypad address]

a. Processor Address — Select a processor address from 1 to 16
b. Link Address —Select link 4, 5, 6, or 8:2 (for RF keypads)
C. Select a keypad address from 1 to 32

5. Action:

Action

Press -

Press
Release
Double Tap
Hold

Br
D

Specifies if the command string to monitor or send should be a Keypad Button Press, Release, Double
Tap, or Hold

6. Button Number:

Selects which button number on the keypad to monitor or send. Pressing a button number will complete
the command selection and will print the command string on the Keypad Button Display area. If a
button is clicked for a Keypad Address and Action that has already been selected, it will simply highlight
the already selected command string.

The Illumination system will allow each keypad on the back end to have 24 operable buttons. Even if the
keypad physically has only 6 buttons with a raise and lower and 2 CCls on the back, the keypad has 24
operable buttons that can be controlled over the network. To view and program these 24 buttons in the
[llumination software, go to the Program tab, and on the Current View drop down menu, select 24
Button Keypad.

The Lower button on Illlumination keypads is typically button 23, and the Raise button is typically button
24. The CCl buttons are typically buttons 19 and 20.

7. Keypad Button Display:

Displays the command strings after the button number has been selected and will scroll down
automatically if there are more command strings that the area can display. Specific command strings
can be highlighted in this area.
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8. Remove Highlighted:
Removes the Highlighted Command String.
9. Generate Driver Button:

Saves the Command Strings into a .csv file for the HomeWorks QS Software to Import (version 8.1 and
newer).

6.0 Importing and Configuring the Driver

Go to Tools > Configure Integration > 3rd Party Commands within the HomeWorks QS software.

Click on Import and select the .csv driver file created by the tool. After importing the .csv file, it will be
added to the left hand column which is a list of the available drivers within the database. Select the
driver by clicking the Driver Set Name. The commands will display on the right-hand side of the
Configure Integration window. Any changes made to the driver in the HomeWorks QS software can be
exported and saved as a .csv file for future use.

Ensure that the Data Type reads ASCII and the R$232 Terminator box is checked. Use the option for
both <CR> and <LF> as the terminators.

3,

) =
e Configure Integration

Integration 3rd Party Commands Telnet Logins
Integration Command Set 001 I Use R5232 terminator |~
Edit Nickname %  Communication Direction Command 8

Login From 3rd Party LOGIN:
Password To 3rd Party hwgs,hwgs
KEP, [01:04:01], 2 From 3rd Party KBP, [01:04:01], 3
KEP, [01:05:03], & From 3rd Party KBP, [01:05:03], &
KER, [01:05:03], 6 From 3rd Party KEBR, [01:05:03], &
KEP, [01:05:03], 7 From 3rd Party KBP, [01:05:03], 7
KBR, [01:05:03], 7 From 3rd Party KBR, [01:05:03], 7
KEP, [01:06:32], 1 To 3rd Party KBP, [01:06:32], 1

Add command set Export Add command

[ Do |
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Login and Password commands will appear above the keypad command strings. These commands are
automatically included when the HW Driver Generator saves the driver. The Password Command will be
populated with the username and password typed into the Generator.

The two systems will communicate over the network. HomeWorks Illlumination will send the “LOGIN:”
string and the HomeWorks QS processor will be monitoring to see this command.

Programming is required to send out the login and password to the lllumination system. Go to Program
> Devices and select the 3rd party controller from the Device Location drop down menu. On the
command with Login as the nickname, program it to send the Password 3rd party command. When the
HomeWorks QS system receives the Login request, the HomeWorks QS processor will send the
username and password fields of the driver to the lllumination system in order for it to establish a
connection.

Once the Login command is programmed, program the remaining Inbound Commands similarly by
selecting each of the inbound command nicknames and assigning the necessary assignable items. These
inbound commands will act like button presses to the HomeWorks QS processor which is monitoring for
communication from the lllumination system. These commands will act as Single Action buttons and can
have normal or conditional programming on them.

m program | devices [w}] activate | transfer | diagnostics

Program Type Normal n

Device Location:

Area 001 » HW Tllum n

[] Use shared scene  Share this scene

Assignable Items | Show Al ¥») Control 3rd Party n n | Current Area n

Prev

S€ 3

Expand all | Collap

=] Area001 A
» HW Illum G Settings | Password n Fade s Delay 0 s
Inbound Commands
Nickname
Login
KBP, [01:04:01], 3
€ Type % Item Description %  Setting
/8 Control 3rd Party  (») Area 001 » HW Hllum Password

KBP, [01:06:32], 1
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If the command direction is from HomeWorks QS to lllumination, program keypad button presses to
send the commands to the HomeWorks lllumination system. Go to any keypad button or other trigger
(timeclock, CCl, etc.), and select the “Control 3rd Party” Assignable Item option to locate and assign a

command.

m program  devices

Device Location:

Area 001 * Control Station 001

Button ca

(v}l activate | transfer | diagnostics
Button Number 2 I Engraving | HW lllum Program Type Normal n Backlight: On ﬂ
Button Type: Toggle n LED Logic: Room ﬂ @ [ Cycle Dim
Press On ‘ Press Off Double Tap Hold
[ Use shared scene  Share this scene
Assignable Items ‘ Show All | (») Control 3rd Party n in | Current Area n
Type §  Item Description %  Setting
Control 3rd Party ») Area 001 » HW Tllum KBP, [01:06:32], 1
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7.0 Troubleshooting

The best way to troubleshoot the third party connection is through the HomeWorks QS software using
Terminal, in the Tools menu. Open a Terminal session to the processor where the HomeWorks
[llumination processor is link assigned. Once connected to this processor, send the command
“outboundconnections” which confirms if both systems are connected via Ethernet (will say “Yes” or
“No”) and displays the previous 10 commands sent and received from the connection.

7, B
& Terminal

Command:

outboundconnections n
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